Pourquoi WordPress 5.6 va casser de nombreux sites en Décembre 2020 ?

5.6 rendra « inutile » le plugin “jQuery Migrate Helper”. Ce qui signifie que certains sites peuvent se casser à nouveau.

Pourquoi WordPress 5.6 va casser de nombreux sites en Décembre 2020 ?

WordPress 5.5 a été déployé en Août 2020 et, peu de temps après, des millions de sites Web à travers l’Internet ont connu des problèmes.

Préparez-vous parce que WordPress 5.6 a le potentiel de faire la même chose.

L’un des développeurs WordPress derrière le plugin jQuery Migrate a déclaré dans un fil de support que le plugin deviendrait « inutile » une fois que la version 5.6 WordPress sera déployée.

N’importe qui qui l’aura encore en fonction sur son site en Décembre 2020 connaîtra de sérieux ennuis, au point de devoir tout recommencer.

Pourquoi WordPress 5.5 a cassé des sites Web ?

WordPress est sur une modernisation prévue en trois phases de l’utilisation de jQuery.

jQuery est un ensemble de scripts qui donne des fonctionnalités de sites Web comme l’animation, fournit des éléments interactifs aux pages Web, rend la création de plugins et de thèmes plus facile parce qu’il gère les fonctionnalités communes aux sites Web et manipule le CSS avec lui.

Les anciennes versions de jQuery sont encore utilisées dans de nombreux plugins et thèmes. Les anciennes bibliothèques jQuery contiennent des vulnérabilités XSS (Cross Site Scripting) et Denial of Service (DoS), ce qui peut être dangereux pour les sites Web.

WordPress 5.5 a été la première étape vers la modernisation de WordPress en forçant l’ensemble de l’écosystème WordPress à mettre à jour leur code et à adopter la dernière et la plus sûre version de jQuery.

La première étape du voyage a été de supprimer la bibliothèque jQuery Migrate 1.x.

jQuery Migrate est un code qui permet à un site Web avec des plugins qui utilisent des versions plus anciennes de jQuery de continuer à fonctionner. Il rend un site WordPress rétrocompatible avec les plugins et les thèmes qui utilisent encore des scripts jQuery plus anciens.

WordPress a annoncé ces étapes des mois à l’avance. Les développeurs de thème et de plugins avaient amplement été avertis que jQuery serait supprimé, leur donnant beaucoup de temps pour mettre à jour leur logiciel.

Lorsque WordPress a publié la version 5.5 en Juillet 2020, des millions de sites Web ont cessé de fonctionner comme ils le devraient.

Certaines personnes ont été verrouillées hors de leurs sites et ne pouvaient pas se connecter à leur panneau d’administration. D’autres éditeurs ont vu l’ensemble de leurs sites cesser de s’afficher entièrement.

WordPress a publié un plugin appelé Enable jQuery Migrer Helper pour restaurer tous les sites web cassés. Des millions de sites Web ont été restaurés et ont continué à fonctionner comme d’habitude.

WordPress a cependant déclaré à propos de ce plugin :

Avec la mise à jour de WordPress 5.5, un outil de migration connu sous le nom de jquery-migrate ne sera plus activé par défaut.

Cela peut conduire à des comportements inattendus dans certains thèmes ou plugins qui exécutent du code plus ancien.

Ce plugin sert de solution temporaire, permettant au script de migration de votre site de donner à vos plugins et auteurs de thème un peu plus de temps pour mettre à jour, et tester, leur code.

Pourquoi WordPress 5.6 pourrait casser certains sites ?

WordPress 5.6 à venir le 8 Décembre 2020 va déployer la deuxième étape de la modernisation de l’utilisation de jQuery en mettant à jour la bibliothèque jQuery Migrate à la dernière version, 3.3.1.

L’effet de ce release est que les sites qui comptent sur le plugin « Enable jQuery Migrer Helper » pour empêcher leurs sites de s’effondrer vont souffrir à nouveau.

Selon l’annonce officielle

La première étape a été incluse avec WordPress 5.5, qui a cessé d’activer jQuery Migrer version 1.x par défaut.

Dans le cadre de… la deuxième partie de ce processus… a mis à jour la version jQuery groupée à 3.5.1. Parallèlement, jQuery Migrate a également été mis à jour à la nouvelle version 3.3.1.

Notez que le script \ »Migrate\ » pour la version 3 n’est pas compatible avec les fonctionnalités pour lesquelles le script de migration précédent a fourni un polyfill pour, et les fonctionnalités précédemment marquées comme dépréciées ne sont plus disponibles.

Cela signifie que les fonctionnalités se briseront à nouveau ou fonctionneront mal à nouveau pour les sites qui s’appuient toujours sur le plugin « Enable jQuery Migrer Helper » pour maintenir le fonctionnement de leur site.

Dans un forum de support de prise en charge du plugin WordPress Enable jQuery Migrate Helper, quelqu’un a demandé si le plugin « Enable jQuery Migrer Helper » continuera à fonctionner avec WordPress 5.6 :

Lorsque la mise à jour WordPress 5.6 arrivera, « Enable jQuery Migrer Helper » fonctionnera-t-il toujours ?

Le développeur de plugins WordPress a répondu :

Donc, pour faire court, c’est non. Il n’aidera pas une fois que WordPress 5.6 sera disponible, comme la bibliothèque jQuery dans WordPress est prévue pour être mise à niveau, et cela rendrait cette aide inutile …

Beaucoup de plugins et de développeurs de thème ont mis à jour leur logiciel à la dernière version de jQuery et résolu le problème. Les utilisateurs de ces produits ne devraient pas avoir de problème.

Mais il y a beaucoup de thèmes et plugins qui ne sont plus maintenus et il peut y avoir d’autres qui n’ont pas encore mis à jour leur code. Les utilisateurs de ces produits verront probablement leurs sites arrêter de fonctionner normalement.

WordPress 5.6 fera-t-il mal fonctionner votre site ?

Si vous utilisez actuellement le plugin « Enable jQuery Migrer Helper » et que, lorsqu’il est connecté à votre panneau d’administration, vous voyez des messages d’erreur, alors oui, vous pouvez rencontrer un comportement inattendu du site Web lorsque WordPress déploiera la version 5.6.

D’autre part, si « Enable jQuery Migrer Helper » ne signale pas d’erreurs, cela signifie que vos thèmes et plugins ont mis à jour leurs bibliothèques jQuery et le site devrait bien fonctionner.

Source : Searchenginejournal 

.tb_button {padding:1px;cursor:pointer;border-right: 1px solid #8b8b8b;border-left: 1px solid #FFF;border-bottom: 1px solid #fff;}.tb_button.hover {borer:2px outset #def; background-color: #f8f8f8 !important;}.ws_toolbar {z-index:100000} .ws_toolbar .ws_tb_btn {cursor:pointer;border:1px solid #555;padding:3px} .tb_highlight{background-color:yellow} .tb_hide {visibility:hidden} .ws_toolbar img {padding:2px;margin:0px}

Auteur : Noel NGUESSAN

Je suis Noel Nguessan, fondateur du site Arobasenet.com qui existe depuis 2007 et a aujourd'hui plus de 6.800 articles. Pour ma part, j'ai intégré le monde de l'internet en 1997 en qualité de créateur de site internet, avant de devenir développeur web et multimédia au début de l'année 2000, avant de basculer naturellement vers le SEO en tant que Consultant.